keywords: ip pbx voip gateway gsm gateway

×

Notice

The forum is in read only mode.
× Questions about B100/200/400/800 ISDN BRI Cards

2xA1200P + B400P - a few problems...

15 years 6 months ago #2214 by james.zhu
hello:
please check that:
1) if you use misdn-init you have to edit the file to detect the card. please refer user manual
2) if the message appears once or two times, ignore that.
regards!
james.zhu

15 years 6 months ago #2219 by vmiro
misdn conf files are configured properly, but the problem is that I need to start misdn-init script twice for the card to be recognized. First time the misdn-init script starts during boot (chkconfig) and the second I do it manually (misdn-init restart).
15 years 6 months ago #2247 by vmiro
I'm getting the following message in my log file every time I make or receive call over mISDN channel:

Debug: sleeping function called from invalid context at mm/slab.c:2063
in_atomic():0[expected: 0], irqs_disabled():1
[<c0120289>] __might_sleep+0x7d/0x88
[<c0148cbf>] kmem_cache_alloc+0x1d/0x57
[<e0bce6dd>] bchdev_echocancel_activate+0x80/0x25e [mISDN_dsp]
[<e0bce5f7>] dsp_cancel_init+0x91/0xa0 [mISDN_dsp]
[<e0bc84e8>] dsp_control_req+0x4c2/0x67d [mISDN_dsp]
[<e0bc88a6>] dsp_from_up+0x202/0x2f2 [mISDN_dsp]
[<e0bc8fed>] dsp_function+0x2a/0x35 [mISDN_dsp]
[<e0a7ee5a>] mISDNStackd+0x325/0x56a [mISDN_core]
[<c0120559>] autoremove_wake_function+0x0/0x2d
[<c02e099e>] ret_from_fork+0x6/0x14
[<c0120559>] autoremove_wake_function+0x0/0x2d
[<e0a7eb35>] mISDNStackd+0x0/0x56a [mISDN_core]
[<c01041f5>] kernel_thread_helper+0x5/0xb

Is it normal or....?
It happens on my two asterisk systems. One is working ok (with B100P), but the one I'm working with now is unstable so I'm wondering is it maybe related with those messages?!
15 years 5 months ago #2254 by vmiro
Anyone ??
15 years 5 months ago #2255 by miaolin
do not meet this bug before, but it looks like something wrong with the mISDN device driver, maybe due to linux kernel imcompatible or bad linux kernel source or you have to compile mISDN again.

what linux you are using?
15 years 5 months ago #2256 by vmiro
CentOS 4.7
I'll try now with CentOS 5.2 and mISDN 1.1.7...
Time to create page: 0.036 seconds
Powered by Kunena Forum