keywords: ip pbx voip gateway gsm gateway

×

Notice

The forum is in read only mode.
× Questions about B100/200/400/800 ISDN BRI Cards

Fax Error with Fax For Asterisk over B100P Card

10 years 7 months ago #9101 by martink
Hi,

in my IPPBX I've implemented an email2fax gateway for outgoing faxes. Once it worked pretty good but meanwhile I cannot send any fax.
About my configuration:
It is a system with Core2Duo processor on a Gigabyte mainboard with 3 telepohony cards. A B100P, a B200P and an A800P.
The B100P is connected to the provider, while the B200P card connects to other local telephony hardware. I use the analog A800P card for the connection to a cable provider via POTS lines, but it is not involved in faxing.
I use Asterisk version 1.8.18, res_fax and the Free Fax For Asterisk module provided by digium.

The fax is received by postfix, passed over to a script which creates a call file and a tiff and passes it to asterisk which then connects over a span belonging to the B100P card. After a while I get errors, either a training error, a 3rd_frm_error, tone errors or no appropiate response from the remote side at all. I've recorded a session, listened to it and I could here unusual clicks from time to time. So this seems all to be related to a poor conection...

Then upgraded from openvox_dahdi 2.6.1 to 2.7.0, because I had the hope to get it up and running again with the newer driver. But, I had no luck.
I cannot remember which driver I used when it worked, but it was probably put together by myself - e.g. not a openvox complete package.
Back then I had no echo cancellation (oslec) on the B100P (HFC-S) card compiled into the driver, but turning it off did not resolve the issue.
The mysterious thing is that I have no problem with phone calls at all. They are very clear...

Since I'm stuck at the moment I ask you guys for an advice about what I can do to further investigate and resolve this issue. In different forums I've read about timing issues beeing a cause of this. Is spandsp involved with oslec? Since I've seen it in the source tree with version 0.0.3. I read about other systems where spandsp let faxes fail, so might this be something I've to investigate?
After the update of the driver I get a notification about /sys/bus/astribanks/drivers/xppdrv/sync missing.

I attached some descriptive files about the system including dahdi_scan and dahdi_test results. If there is something important missing or you need a debug run of a fax call I will provide them on request.

http://www.krellmann.net/upload/fax.zip
http://www.krellmann.net/upload/dialing.zip

Thank you so far.
Best regards,
Martin.
10 years 7 months ago #9102 by martink
Hi,

i forgot a lspci and an overview of the interrupt assignment...

http://www.krellmann.net/upload/pci.zip

Greets,
Martin.

i] Last edited by martink at 2013-10-3 21:50 [/i
10 years 7 months ago #9104 by tim.june
Hi Martin,
can you remove the A800P & B200P, leave only B100P on your server to test the fax?
pls contact me via skype below for better communication?

Email: This email address is being protected from spambots. You need JavaScript enabled to view it.
Skype: tim.jjune
10 years 7 months ago #9116 by martink
Hi Tim,

I will check this at the end of this week (Friday or Saturday). Until then i cannot remove the cards.
Will it be sufficient to switch them off in the config? Or should I physically remove them?

I also bought a SATA SSD module so that I can remove the ide flash card... And another plan is to switch off some of the internal peripherals to free irqs.

I will then provide you with my findings via Skype.

Best regards,
Martin.
10 years 7 months ago #9119 by tim.june
Hi Martin,
Unload the the driver for A800P & B200P will be ok, i just want to figure out if it is because of timing issue. Leave only B100P working on the server and test the fax. I am waiting you on skype.

Email: This email address is being protected from spambots. You need JavaScript enabled to view it.
Skype: tim.jjune
10 years 6 months ago #9234 by martink
Hi Tim,

unfortunately I wasn't able to get back to you until now.
Meanwhile I've migrated the pbx to an ssd and removed the cf card.
Now I get better results with dahdi_test:
Best: 99.999% -- Worst: 99.317% -- Average: 99.826100%

But the issue remains. Additionally, there are clicking sounds In the rx channel of voice calls passing the B100P
Deactivating the other cards did not resolve the problem.

This is the current interrupt assingment:
CPU0       CPU1
  0:   30644596      25364    IO-APIC-edge  timer
  1:        118          5    IO-APIC-edge  i8042
  8:          1          2    IO-APIC-edge  rtc
  9:          0          0   IO-APIC-level  acpi
 12:          3          1    IO-APIC-edge  i8042
 14:          0          0    IO-APIC-edge  ata_piix
 15:       8390      39323    IO-APIC-edge  ata_piix
 50:        247     155482         PCI-MSI  eth0
 58:        215          0         PCI-MSI  hda_intel
 66:    1824942   28813928   IO-APIC-level  b4xxp
169:  328649445          1   IO-APIC-level  uhci_hcd:usb5, vzaphfc
217:          0          0   IO-APIC-level  ehci_hcd:usb1, uhci_hcd:usb2
225:      11276   30623894   IO-APIC-level  uhci_hcd:usb3, opvxa1200
233:          0          0   IO-APIC-level  uhci_hcd:usb4
NMI:          0          0
LOC:   30653495   30653213
ERR:          0
MIS:          0

What about the missing /sys/bus/astribanks/drivers/xppdrv/sync?

I've added you on Skype.

Greets,
Martin.
Time to create page: 0.037 seconds
Powered by Kunena Forum