keywords: ip pbx voip gateway gsm gateway

×

Notice

The forum is in read only mode.
× Questions about B100/200/400/800 ISDN BRI Cards

B800p with bristuff

15 years 6 months ago #2121 by admin
I think the right driver is qozap.ko . zaphfc.ko is the driver of 1port ISDN card.

Please scan
www.openvox.com.cn/downloadsFile/1195091231.pdf
15 years 6 months ago #2122 by sebek72
but lspci recognizes the card as:

0000:01:01.0 ISDN controller: Cologne Chip Designs GmbH ISDN network Controller [HFC-8S] (rev 01)

Any specific hit how to disable old modules and enable new ones?

Thank you.
15 years 6 months ago #2124 by james.zhu
hello:
the info is for B800P. could you patch the file for B800P? make sure compile the bristuff with patch for B800 and without error.
regards!
James.zhu

15 years 6 months ago #2127 by sebek72
I tried using qozap.c (openvox patch) and recompiling briistuff.
(it warned me, that in have some modules installed from before) other than that i went ok. i'm using
bristuff-0.3.0-PRE-1q

but the ztcfg -vvvv still gives me:

ZT_SPANCONFIG failed on span 1: No such device or address (6)

this is a part of compile log:

/root/bristuff-0.3.0-PRE-1v/qozap/qozap.c:1870: error: ‘struct qoz_card’ has no member named ‘st_sync’
make[2]: *** [/root/bristuff-0.3.0-PRE-1v/qozap/qozap.o] Error 1
make[1]: *** [_module_/root/bristuff-0.3.0-PRE-1v/qozap] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.15-25-686'
make: *** [linux26] Error 2
install -D -m 644 qozap.ko /lib/modules/`uname -r`/misc/qozap.ko
install: cannot stat `qozap.ko': No such file or directory
make: *** [installlinux26] Error 1
****************************************************
quadBRI driver installed.
Press <Enter> to continue, or <CTRL> + <C> to abort.
****************************************************



What am i doing wrong?

Thanks.
15 years 6 months ago #2129 by james.zhu
hello:
i think you have a compilation error there, you have to solve that. if possible, please follow the installation procedures exactly. it will cause the error if use different versions of bristuff.
regards!
James.zhu

15 years 6 months ago #2133 by sebek72
i tried with the new version, but still the same...
i also have no genzaptelconf command.

I can only do this:
/bristuff-0.3.0-PRE-1v/zaptel-1.2.10/xpp/utils# ./genzaptelconf -dv
Unloading zaptel modules:

Temporarily moving zaptel.conf aside to work around broken modprobe.conf
Test Loading modules:
- zaphfc
- qozap
- ztgsm
- wctdm
- wctdm24xxp
- wcfxo
- wcfxs
ERROR: Module wcfxs does not exist in /proc/modules
- pciradio
- tor2
- torisa
- wct1xxp
- wct4xxp
- wcte11xp
- wanpipe
- wcusb
- xpp_usb
Generating '/etc/zaptel.conf and /etc/asterisk/zapata-channels.conf'
Reconfiguring identified channels

Zaptel Configuration
======================


Channel map:


0 channels configured.


Any clues?
Time to create page: 0.041 seconds
Powered by Kunena Forum